PDA

View Full Version : SR20DET boosting high?



uiuc240
12-10-2001, 02:55 AM
I fully intend on running 10-12 psi with this motor come springtime, when I have the time and money to get all the proper parts. However, at the current moment, the motor is spiking to 10 psi! It should be at 6-7?!

The boost cut is installed, and all the vacuum lines are good to go. The boost builds quickly, and it pulls really hard. However, when the boost cut kicks in, it's like a misfire almost. Feels like the speed limiter, only less intrusive and faster recovery. Anyway, I'm just trying to see if you all had any ideas as to why the boost might be so high? What should we start checking? Thanks! http://www.freshalloy.com/

Eric

KenFuji
12-10-2001, 03:29 AM
yes it should be 7psi...

i'm not sure, but my guess is bad or sticky wastegate...

just a guess http://www.freshalloy.com/

MI SO FST
12-10-2001, 07:59 AM
HEy, I see that you are from IL too, are you going to school down there or do you live there? Where did you get your swap done at?

I well be holding another 240sx meet in the spring time.

E-mail me at misofst@aol.com.

uiuc240
12-10-2001, 09:55 AM
the wastegate has already been thought of. but that's *not* what i hope it is. http://www.freshalloy.com/ http://www.freshalloy.com/

does anyone have any other ideas????

http://www.freshalloy.com/

NY S13 SR
12-10-2001, 10:59 AM
Why are you running the boost cut? Remove it! Run a vac hose directly from IC piping to wastegate actuator. We never use the stock boost sensor/controller. 8-9 psi is normal with a 3" downpipe, nothing to be worried about.

__________________________
Jeff Holden
Heavy Throttle Performance
www.heavythrottle.com (http://www.heavythrottle.com)

oberkill
12-10-2001, 11:07 AM
Jeff when it is run that way the boost creeps up to ~12 then settles at 11. The boost cut was only added when the boost just would not come down. Right now it creeps to 10 then settles at 8/9. The vacuum lines were changes and rerouted a few different ways with no change. He is running a SMIC. No idea why it wont go down, the engine had sat outside for awhile sometime during its life and things were/are pretty dirty. Can the wastegate get clogged up and if it so can it be cleaned? I do have a spare to put in now that I have some time so I may try that this weekend.

Alan