PDA

View Full Version : Dyno Results: S13 SR 218HP



Akumaxkun
10-25-2004, 07:19 PM
I got my car dynoed tuned today at R&D Dyno down in Gardena, CA. This is with a t25 turbo running 11 psi. Overall, i was pretty happy with my results. Heres the dyno graph.

http://img.photobucket.com/albums/v296/akumaxkun/1231.jpg

The blue is what i started with, 187 hp and 197 tq,
after some tuning i ended up with 218hp and 221 tq.

My list of mods are:
Greddy o2 extension
3" DP
Blitz Nur Spec R
Z32 MAF
Apexi Air filter
APexi SAFC
Blitz LM FMIC
Recirced HKS BOV

SlowImport
10-25-2004, 07:33 PM
Sweet. What did you use to tune it?

congrats,
Josh

LOwrestling2001
10-25-2004, 07:35 PM
i would have to say..his s-afc.

JimStinksAtDorifto
10-25-2004, 07:37 PM
I'm assuming you kept it low because fo your lack of a fuel pump?

Akumaxkun
10-25-2004, 07:56 PM
actually i forgot to mention that i have a walbro fuel pump

Five10PacksDE
10-26-2004, 11:24 AM
Nice, not everyone gets that big of hp #'s as you did.

hybrid_eg
10-27-2004, 04:59 PM
hmm.. i'm thinking it should have been a little more no?

I ran mine almost stock.. mint red top, 11psi, ebay dp,apex n1, hks headgasket i think its 1.6, k&n filter, SX FPR, Z32 pump, stock mount.. 215whp and stock was 194whp i believe.

Either way thats enough HP as long as your car is a stripped chassis, has an LSD and some decent tires.. you're good to play with mid 13's cars :-)

Akumaxkun
11-02-2004, 02:31 PM
stock was 194whp? thats quite a bit for stock aint it?

knate
11-02-2004, 04:27 PM
I'm sure he meant stock boost. Just about nobody dynos a *truly* stock SR in the US (airbox, etc.)

_Def_
11-02-2004, 04:29 PM
hmm.. i'm thinking it should have been a little more no?

I ran mine almost stock.. mint red top, 11psi, ebay dp,apex n1, hks headgasket i think its 1.6, k&n filter, SX FPR, Z32 pump, stock mount.. 215whp and stock was 194whp i believe.

Either way thats enough HP as long as your car is a stripped chassis, has an LSD and some decent tires.. you're good to play with mid 13's cars :-)




Sounds about right. I have a Trust turbo outlet and about the same mods as you(minus the headgasket, mine is stock). Running ~10 psi in the midrange and tapering to ~9 psi up top gave me 205rwhp/200rwtq. Had no fan on my tiny stock SMIC either, but the horsepower stayed the same run after run. Which leads me to believe it basically heatsoaked first run and didn't have any air on it...

red_giant
11-02-2004, 11:25 PM
decent numbers, but something i found weird is that i have you SAME exact setup (brands and all) except i don't have a z32 maf and i don't have my safc hooked up and i hit 230whp/230 ftlbs on only 10 pounds of boost. weird.

cwdmark
11-03-2004, 05:00 PM
turn up the boost next time. its safe to run 14-15psi at the dyno.