PDA

View Full Version : steady knocking coming from head



gpeele
05-08-2005, 06:16 AM
hello, i just got finished doing a swap on my 89 240hb. its a 95 rps13 blacktop with a pfc d jetro, apexi pfc boost control kit and a hks dli. i have other various bolt ons but nothing that would contribute to this i dont think. well yesterday replaced the water pump due to a bad bearing and some leakage.

today i took it to 3000rpm, everything sounded good so kept going until my rev limiter kicked in at 5000rpm(i set it at 5000k until i get the bugs sorted out). my car looses a lot of power so i pulled back in and saw that my intercooler hose had popped off and a steady knocking sound was coming from the front of my head that would go up and down with the rpms, it sounds like a mechanical knock sound.

the knock meter on the pfc doesnt read anything right now although it was picking up trace amounts of knock a couple of times on previous days when i would let off the trottle suddenly. by trace amounts i mean one or two bars for a second at the most. i let the car cool down and sit for a while and i started it again. the knocking sound is still there and is steady with rpms, also when the engine would start warming up the idle gets worst.

i have my boost set at .8 bar. and i havent touched the base maps since i just got finished hooking up everything for the swap. the only things i touched on the pfc were the boost control option, setting boost at .8 bar and the new 5k redline. i cant really think about anything else that would be useful information but if you need to know anything else about the car please ask. thanks in advance for your help.

rogoman
05-08-2005, 08:20 AM
The metallic knock may be the top timing chain guide having broken off. Take the valve cover off and check it out.

gpeele
05-08-2005, 05:14 PM
thx will do. im also open to anyother ideas, it will be a few days till i can check it out. my friend is using the garage for his chevelle and the apartment complex is very strict about working in the lot.

TS4l
05-09-2005, 10:03 AM
Also could be your Hydrolic Lash adjusters need to be bled. When you have the valve cover off, push down on the rocker arms, if they go down then you need to bleed the HLA's!

gpeele
05-09-2005, 03:20 PM
i hope its that and something didnt break, i take it that the procedure is in the s14 fsm and that its the same for the s13 as it is for the s14. thanks for the advice.