PDA

View Full Version : Noisy lifter, oil on #2 plug, car hesitates @4500



GoaTSLonG
05-19-2005, 07:12 PM
yea so like i said the car started hesitating and bucking hard at around 4500-5500 rpm when i floor it in any gear besides 1st but if i keep it floored it "breaks through" the hesitation and then revs fine to redline. things i checked/fixed.

car wasnt running an o2 sensor it just wasnt plugged in, plugged it in and no change.
wired in an avcr the day before this started happenening so i cut out the avcr wiring and resoldered the ecu wires together.
swapped out my coilpacks with known working coilpacks.
checked for boost leaks

then i noticed that 1,3,4 spark plugs were nice and clean but #2 was covered, dripping, in oil. i also noticed that there is a knocking noise coming from the valve cover and seems like right under #2 cylinder. could a out of adjustment or faulty lifter/rocker cause the spark plug to be covered in oil/bucking @4500rpm? if not i need some suggestions.

btw car is an s13 with redtop sr, 50# injectors, z32 mafs, hks step 2 cams, greddy valve springs, rocker arm stoppers, enthalpy rom tune and all the other goodies.

chunk
05-19-2005, 07:23 PM
Could be leaky valve seals letting oil run down the valves. S13 redtop is a pretty old motor and seals like that dont last forever.

GoaTSLonG
05-19-2005, 07:39 PM
the head has to be pulled to replace that huh? is there anyway to check to make sure it is that?

ItzGenX
05-19-2005, 09:21 PM
Do a leakdown test.

GoaTSLonG
05-20-2005, 03:30 PM
thats it?