PDA

View Full Version : AC Help 89 ka24e to 92 ka24de



Darkroom1428
06-27-2005, 05:01 PM
I swapped in a ka24de into my 1989 fast back everthing works fine but i need AC.
I installed the 92 compressor (i had to splice in 92 wiring harness). I use the ka24de ac lines i swapped the black box under the dash. and i'm using the ka24de condensor.
When i tryed to recharge the system the compressor is not kicking on. so i hot wired it by just wiring the positive to the single wire on the compressor. and my system is charged also the ac is cool but this is when i have the jumper wire hooked up. the relay i'm using is good. but when i press the ac button the compressor does not kick on also the fans don't kick on.
So any help would be appreciated.
Thanks
lee

rogoman
06-27-2005, 10:01 PM
I would venture to say that there's some sort of wiring mismatch between the A/C wiring and the new ECU. I assume you now have a KA24DE ECU.

RDM_II
06-27-2005, 11:55 PM
Blue/green at the ECCS plug and dash plug. Make sure both sides are wired up.

champa
06-28-2005, 12:30 PM
Blue/green at the ECCS plug and dash plug. Make sure both sides are wired up.



I did this same exact swap about a year ago into my '90. i'm almost positive that this connector is different on the DE compressor. that means you need to cut off this connect from the harness and solder the DE connector in it's place.

Darkroom1428
06-28-2005, 01:22 PM
Thanks for the info guys. i checked the blue and green wire on the harness for the dash and ecu. i connected it and now the ac works fine.
the compressor harness is different but i soldered the dohc harness in place of the sohc harness. so i'm using the 92 dohc compressor.
Thanks again lee

RDM_II
06-28-2005, 03:12 PM
Thanks for the info guys.



Send beer soon.