PDA

View Full Version : Burning OIL...



Silly40sx
07-20-2005, 04:00 PM
Okay so i got my sr swap one year ago.. and i have been using Royal Purple full synthtic, 50/20 . I noticed oil on the turbo ( dunno if it is on compressor or turbine, it is closer to the font of the car, i am assuming it is the compressor) Ok its doesn't smoke all the time. If i am cruzing around at constant speed and come to a stop it puffs, or if i don't drive for 2 days and start up it smokes. My friend, who was eating my smoke lol, said when i took off the line alot of smoke came out, not black but white/bluish. http://forums.freshalloy.com/images/graemlins/tear.gif

_Def_
07-20-2005, 08:45 PM
The seals probably died on the turbo. So you're dumping oil in the turbine housing then when you get on it it burns it. The result is that nasty smelling whitish/grey smoke.

Good news is that if you're still on a T25 you can source a replacement for pretty cheap, or you can use this as a nice opportunity to upgrade.

Silly40sx
07-21-2005, 09:38 AM
sweet time to get a t28, for now that all i can afford. but The mechanice still recommeds that I do a compression test. But i agree with you that my turbo is going.

_Def_
07-21-2005, 12:54 PM
I would do a compression test as well. You can pick one up for pretty cheap, and it's good piece of mind. Just pull the plugs, warm the engine up, then pull the CAS plug, screw it in, step on the throttle and crank the engine a few times. Repeat for all cylinders.

Or you can get a mechanic to do it for a little bit, but it's honestly as easy as changing your spark plugs.

Silly40sx
07-22-2005, 11:46 AM
Thanx a million for your advice. Also i know i am not suppose to ask 'classified' questions, but you know where i can get a t28 bb turbo? for fairly cheap?