PDA

View Full Version : Popped My Motor - 9.0:1 8300rpm build - *more pics



SequenceGarage
08-01-2005, 12:04 PM
So I went to a drift competition in montreal this weekend and on my 3rd practice run my motor stopped idling smoothly, and after my 4th run the thing dumped out tons of blue smoke from the exhaust (no oil catch can) and would try to stall any time there wasn't more than 10% throttle.

Compression - 150 - 60 - 150 - 0

So how did it blow? I have an AEM EMS and the log shows a peak of about 8.5-9psi on the map sensor although i was running 16-17psi all day. O2 sensor log : 16-17:1 any time in boost. She lasted 3 runs like this!! I was impressed. Anyways, i figure there was too much draw off of my 5v sensor feed because thats what i have powering my boost control solenoid, as well as a variable resistor for my traction control sensitivity - the variable resistor i just wired up before this event, SUCKS!!

First time blowing a motor and let me tell you when you're at an event wanting to compete it is a [censored] PISS OFF. Anyways im over it, and i'm gonna order some CP pistons today and im wondering

I want a bit more out of boost torque and response, so im thinking 9.0:1 pistons, just run a bit less timing and maybe a bit more fuel, sure i wouldnt make as much power per psi of boost but out of boost i'd have a bit more response, worth it imo for a quicker spooling race car, any suggestions on how to re-tune the map for this setup?

I'm also going to order valve springs, a metal head gasket and rocker arm stoppers. Will this be enough for 8300rpm?

I want to set my limiter to 8000rpm because often times when i'm drifting (like this weekend) I just want a BIT more rpm to make it what feels like 5ft further before linking the next turn, so it would be pretty light load opperation, i wouldn't drag race or road race up there, not unles i get dirty cams anyways.

Advice on the best springs to get would be great too.

Pics later on today

DTSS
08-01-2005, 01:50 PM
if your already going to be running a good set of valves and retainers then there is no need for rocker arm stoppers, since you wont run into valve float issues at that high of a rpm. But they might be a good idea if your planning on using your 2 step at high rpm's.

cwdmark
08-01-2005, 03:31 PM
O2 sensor log : 16-17:1 any time in boost. She lasted 3 runs like this!! I was impressed.


that's how she blew. how can you be impressed with this? having your motor run for just three runs flat out sucks.

you can't just up your rev limiter and expect nothing to happen without any support mods. that's just plain stupid.

SequenceGarage
08-01-2005, 08:48 PM
O2 sensor log : 16-17:1 any time in boost. She lasted 3 runs like this!! I was impressed.


that's how she blew. how can you be impressed with this? having your motor run for just three runs flat out sucks.

you can't just up your rev limiter and expect nothing to happen without any support mods. that's just plain stupid.



lol are you kidding me?

maybe re-read what i said. I was impressed it lasted 3runs running so ridiculously lean, im surprised it didnt blow up sooner.

Obviously im raising my rev limiter AFTER getting the support mods.. read?

redhanded
08-02-2005, 12:04 AM
i am also interested in info about a 9:1 build up as i am currently in the process of ordering parts for my SR buildup. it would be nice to have a little more power when the turbo is spooling. thanks

killjoy
08-02-2005, 11:58 AM
I remember talking to Scott awhile ago and he said 9.0 pistons is a must for a rebuild.

champa
08-02-2005, 12:10 PM
iím currently in the process of rebuilding my sr with CP 9:1, stock rods, oem rod and main bearings, cometic hg, and power fc. let me know if you guys have questions.

Kingtal0n
08-02-2005, 08:06 PM
So I went to a drift competition in montreal this weekend and on my 3rd practice run my motor stopped idling smoothly, and after my 4th run the thing dumped out tons of blue smoke from the exhaust (no oil catch can) and would try to stall any time there wasn't more than 10% throttle.

Compression - 150 - 60 - 150 - 0

So how did it blow? I have an AEM EMS and the log shows a peak of about 8.5-9psi on the map sensor although i was running 16-17psi all day. O2 sensor log : 16-17:1 any time in boost. She lasted 3 runs like this!! I was impressed. Anyways, i figure there was too much draw off of my 5v sensor feed because thats what i have powering my boost control solenoid, as well as a variable resistor for my traction control sensitivity - the variable resistor i just wired up before this event, SUCKS!!

First time blowing a motor and let me tell you when you're at an event wanting to compete it is a [censored] PISS OFF. Anyways im over it, and i'm gonna order some CP pistons today and im wondering

I want a bit more out of boost torque and response, so im thinking 9.0:1 pistons, just run a bit less timing and maybe a bit more fuel, sure i wouldnt make as much power per psi of boost but out of boost i'd have a bit more response, worth it imo for a quicker spooling race car, any suggestions on how to re-tune the map for this setup?

I'm also going to order valve springs, a metal head gasket and rocker arm stoppers. Will this be enough for 8300rpm?

I want to set my limiter to 8000rpm because often times when i'm drifting (like this weekend) I just want a BIT more rpm to make it what feels like 5ft further before linking the next turn, so it would be pretty light load opperation, i wouldn't drag race or road race up there, not unles i get dirty cams anyways.

Advice on the best springs to get would be great too.

Pics later on today



You say your AEM was logging 8-9PSI, but you were running 16-17PSI. Doesnt that concern you? it sounds like your AEM's fuel map was getting data from the 8-9PSI area for fueling because of a fauly map sensor or input setting. I've only seen that happen once, and it was because an owner chose a 2barmap when he actually had a 3bar map installed... same situation too.

MrWright
08-02-2005, 10:54 PM
So whats the general concensous on 9:0 to 1 pistons. I am thinking about buying the weiscos, cause they are the best pistons around.

But my goal is to gain a little more torque, as my car is a track car. I would like more bang per psi, but i still would like to just be able to use 94 octane.

SequenceGarage
08-03-2005, 12:04 AM
man you guys need to learn how to read.

The car leaned out BECAUSE the map sensor failed. It failed in that it only saw 9psi when the actually intake manifold pressure was 16-17psi. That is why it ran lean. That is why there is a hole in my 4th piston.

I'm pretyt sure i had the 3bar map loaded in the config im thinking there was too much draw on the 5v sensor wire and it caused the voltage to only be about 4v at high load, making the output voltage from the sensor lower as i explained earlier. I'm going to test my map sensor first thing when the motor is back together and make sure that it is reading correctly and go to the dyno for a slight retune along with an air intake temperature sensor, setup the 02 sensor feed back propoerly as well as knock sensor proporly to safeguard my motor against another failure

Anyways today I ordered 9.0:1 CP 87mm pistons and an 88mm cometic head gasket from enjuku, i love those guys, shipped it out about 20min after i ordered it, thanks guys!!

sounds like this is a good combo, im sure i'll be happy with it.

Today we tore the block apart took the head apart it all looks good, i guess i'll need new valve seals and all new gasket stuff now, where can i get a gasket kit for the SR without the head gasket? Thanks.

Pics of the blown piston and rocker arm:

http://www.sequence-garage.com/forums/uploads/post-19-1123048891.jpg

http://www.sequence-garage.com/forums/uploads/post-19-1123048920.jpg

and the only picture i have from the event (as i only was able to do liek 3 practice runs at 9am)

http://www.mox.ca/photos/20050731dm1/CRW_5992.jpg

SequenceGarage
08-05-2005, 04:27 PM
So the motor is entirely disassembled now, the bare block and CP pistons sent to the machine shop today, will lap the vales and pull valve seals over the weekend, reassemble wih new bearings and valve seals on monday/tuesday when the motor gets back from the machine shop and then in the car and running thursday, wear it in on friday, and take it to the track on saturday. Tons of time.

Heres the piston out of the block, i think its a bit broken

http://www.sequence-garage.com/forums/uploads/post-16-1123275870.jpg

http://www.sequence-garage.com/forums/uploads/post-16-1123275916.jpg

cylinder wall was a bit damaged but i got 40thou over pistons so the bore will clean that all right up. Speaking of which, the CP pistons impressed. Very nice packaging, just overall left a good impression with me. The cometic hg on the other hand.. ehh just looks and feels cheap. As long as it does the job. I wont be getting valve springs this round through, money issues

http://www.sequence-garage.com/forums/uploads/post-16-1123276016.jpg

http://www.sequence-garage.com/forums/uploads/post-16-1123276037.jpg