PDA

View Full Version : HELP on CAS install on S14 Kouki SR20DET



DenBellaS14
08-05-2005, 11:49 PM
Here is my dilemma.
I installed the CAS following the FSM. Setting #1 cylinder in TDC (#1 cam lobe facing outwards and crank pulley on the 2nd line from the left.) Also removed valve cover to line up cam gear marks to dark timing chain links.
Engine started but to get 15deg base timing, the CAS is completely off the mounting bolts. To secure the CAS the best i can do is 17deg base timing. Went out to test drive and the car is way slow and engine sometimes stalls on idle. Started over and made sure the dots lined up correctly (removed valve cover) still no luck.
Stumped, I went to go check a friends S13 SR20DET. The engine is running normal and the CAS was never been removed from the factory. Started the car and waited for water temp to reach 85deg and checked timing. Found timing was at 32deg!!!

Now I am really confused. I set the S13 SR20DET to TDC and removed the CAS and found the dots are 180deg over. Reinstalled the CAS and borrowed another timing gun (Snap-on). Results are the same.
Before I try to go 180deg over on my S14, I just want your guys opinion and suggestions.
Thanks in advance,
Daniel
http://forums.freshalloy.com/images/graemlins/crazy.gif

DenBellaS14
08-06-2005, 01:51 AM
just a friendly bump!

Ichiyonsilvia
08-06-2005, 11:13 AM
Search, we have so many post for SR Timing (http://forums.freshalloy.com/ubbthreads/showflat.php?Cat=&Board=UBB9&Number=67952340&Forum =UBB9&Words=sr%20timing&Match=Entire%20Phrase&Sear chpage=0&Limit=25&Old=allposts&Main=67952320&Searc h=true#Post67952340).