PDA

View Full Version : Help!!! Car sounds like a v8 and runs poorly



alpalwal
02-22-2006, 10:16 PM
I'm trying to get my ka-t running reliably and it just isn't working....
Fisrt I had the turbo too close to the block and it melted a couple wires (fixed) and was all bad.

I moved the turbo to more towards the front and towards the drivers fender more. It's all piped up and it should be running fine.

The idle is mostly good... occasional stalling..
Part throttle cruising is fine
When i get above like 50% throttle it coughs and sputters like no other... You'd think boost leak but I'm still making 2 lbs part throttle, and it climbs if i get on it a bit.. I haven't tried full throttle because it can't even handle half.
It sounds like you're rolling your tounge and couging at the same time if you can imagine.

I've looked extensively for boost leaks and I'm not seeing any.. any ideas?

garrett .48, .60 t3
safc2
dsm 450's
sohc ka
Safc - -42 for the low
-39 to -30 for the high untill I find a wideband

Ovrated
02-23-2006, 12:18 PM
Sounds like its missing.. or there is a boost leak you cant find..

check your gap on your plugs, and go to home depot, and make a boost leak tester, and find ALL The leaks that way.. you will find things you didnt think were leaking..

good luck

Brad
02-23-2006, 03:52 PM
keep in mind that negative percentages will advance your timing when using an SAFC. i was running -20% ish levels on an SR and had to drop my base timing a degree or 2 to run the normal boost levels for my setup

TS4l
02-23-2006, 05:22 PM
I'd suggest trying a power balance test, if it sounds like a V8 it could have dropped a cylinder. Start by checking for spark on each cylinder, then fuel injectors spraying, and if all else fails I'd check your compression. I'd start there and report back with what you find out.