PDA

View Full Version : 94 G20t engine noise and tach went dead



soloX
03-06-2006, 05:03 PM
Hi all- new to the forum, after lurking for a few years! I just bought a 94 G20t, 5sp, stock, 60k miles, well cared for. There is a "whine" noise with the motor- coming from the pulley area. Increases/decreases with revs; the techs noted last year that it needed all 3 motor mounts. The PO hadn't done it. Will this cure it?
Also, the tach went dead on me while driving it home. It now barely moves, slowly, clockwise (actually, just like a minute hand on a clock!)...I noticed the tach cable is loose on its pulley- about a 3/4" amount. Can it be fixed just by tightening the cable?
Thanks in advance!

Ev_eezy
03-08-2006, 01:28 AM
I wouldn't think motor mounts would cause a whine. Is it a whine or a high pitched squeal? You might need to replace the belts.

As far as the tach is concerned. It's a fairly common problem on G20's. The least expensive way to go is to just get a new guage cluster from a junkyard and swap out the odometer and speedo. The other way would be to just replace the entire cluster all together with a new one. They do go bad after all...

camber
03-08-2006, 03:32 PM
+1 on not being motor mount.

Check to see if the whine is not being caused by the alternator, AC, water pump etc...

Anything that is being driven by a belt basically!

soloX
03-09-2006, 02:55 PM
Hi thanks for the reply; The noise is a true "whine", at idle it's fairly loud, and mid-range sounding, and at higher revs (2800+) it gets quieter and slightly higher pitched.

I was reading up and someone says that this is common- the Timing chain guide is what causes it, and supposedly, you can remove the guides on these older versions of the SR20DE, since the newer versions didn't have them- AND, a service bulletin came out showing to remove the guide as the FIX for this noise! Is this correct?

If you like, you can call me at 702-756-4782, or email me direct at 78soloX@gmail.com

Thanks,
Greg http://forums.freshalloy.com/images/graemlins/rolleyes1.gif

camber
03-09-2006, 06:08 PM
Don't have any real experience with this motor but I did find this... Check it out!

HOW TO: Remove upper timing chain guide (http://www.sr20forum.com/archive/index.php/t-88199.html)





Some SE-R owners have had an issue with a metallic rattling noise at idle when the motor is hot. Usually, this rattle is attributed to two things: either the timing chain tensioner, or the upper timing chain guide.

This write-up is catered to showing you how to remove the upper timing chain guide in case this noise comes up.


To begin, start removing the valve cover bolts. Also remove the bracket that holds the cruise control cable and the crankcase ventilator.


http://img.photobucket.com/albums/v105/harris81/My%20B13/ac56.jpg

http://img.photobucket.com/albums/v105/harris81/My%20B13/602e.jpg

This is the timing chain guide. Over time, the timing chain starts hitting this guide, therefore causing the rattle at idle.

http://img.photobucket.com/albums/v105/harris81/My%20B13/4364.jpg

Start removing the two bolts that hold the timing chain guide.

http://img.photobucket.com/albums/v105/harris81/My%20B13/5672.jpg

Remove the timing chain guide.

http://img.photobucket.com/albums/v105/harris81/My%20B13/6f8b.jpg

Make sure this is what you take out.

http://img.photobucket.com/albums/v105/harris81/My%20B13/fa78.jpg


No more timing chain guide!

http://img.photobucket.com/albums/v105/harris81/My%20B13/9298.jpg

After having removed the timing chain guide, I noticed that there were deep grooves that were made on the underside of the guide. This most likely happened due to the timing chain hitting the guide for a long, long time.

Now that the timing chain guide has been removed, start closing up the motor. Make sure you donít have any extra bolts sitting around! Also remember to torque down the valve cover bolts to the correct specifications as outlined by the Factory Service Manual.

http://img.photobucket.com/albums/v105/harris81/My%20B13/4e56.jpg

Have fun driving your car rattle-free!

soloX
03-09-2006, 08:32 PM
Thanks, that's actually the EXACT conversations/threads that I found, so I'm glad I wasn't seeing things....now I'm just curious if any Nissan/Infiniti techs have done this and can vouch for the procedure?
Greg http://forums.freshalloy.com/images/graemlins/rolleyes1.gif http://forums.freshalloy.com/images/graemlins/star-wars-smiley-010.gif

camber
03-09-2006, 10:08 PM
Write-up: how to remove upper timing chain guide (http://nissanforums.com/showthread.php?t=55949)

Walkthrough on getting rid of RATTLING (http://nissanclub.com/forums/showthread.php?mode=hybrid&t=71156)

There are threads on FA about this issue but google search is better then one here http://forums.freshalloy.com/images/graemlins/wink.gif

camber
03-09-2006, 10:45 PM
But to be a 100% honest you should ask someone in the 240SX section. They know the most about these engines.