PDA

View Full Version : Got a '90 240sx hatch, Now I need parts. (PLEASE READ)



**DONOTDELETE**
02-05-2002, 05:36 AM
I got my car last last, hooray! So I need some help hereto fix what's wrong with it.

When I rev the engine the engine will actually tilt a good 4 inches either direction, so I know I need engine mounts, but I'd like to know how much work that is??????

Plus I think the timing chain is clicking http://www.freshalloy.com/
I remember hearing that this is pretty bad so I hope I can get it fixed asap. So I'll need advice on how to fix this.

I plan on doing the work myself, with the help of my brother who is a Lincoln Tech student. So any advise or references you guys give is appriciated.

mrmephistopheles
02-05-2002, 07:42 AM
Motor mounts aren't TOO hard.. you'll need to lift the motor up with a hoist as well as disconnect the tranny from driveshafts iirc..

The timing chain doesn't usually click.. if it's getting ready to go you'll hear a nice bad scratching/crunching sound when you startup. You're probably hearing your lifters tapping? I don't know too much about SOHC, so you'll need to get the advice of a SOHC owner who's had lifter tapping.

Kevin

**DONOTDELETE**
02-05-2002, 08:23 AM
oh crap lifter tapping sounds worse than the chain.... does that mean the valves are floating?

ringer
02-05-2002, 09:11 AM
The ticking could also be the injectors. Mine are loud as hell. http://www.freshalloy.com/

iceman
02-05-2002, 09:14 AM
my 90 has a loud 'tapping' aswell, faint at idle louder and faster at WOT.
does that sound more like lifters or injectors?

**DONOTDELETE**
02-05-2002, 11:10 AM
What kind of noise would the injectors make? The kind of tapping,or clicking, from my engine is only noticable when you stand next to the car with the hood open, but what I don't get is the noise sort of disapears when the engine revs http://www.freshalloy.com/