PDA

View Full Version : 2000 G20 front suspension noise



boluca
08-12-2009, 03:36 PM
Noise in 2000 Infiniti G20, 170,000 miles, automatic, when you hit a sharp bump in the road there is a loud thump, thump or shudder noise in left front. Everyone that rides in the car think it is under car or left front. Has to be a sharp bump, normal bumps sound fine. Sounds like suspension or a strut. I had a garage check when having it inspected and they said struts. I replaced the struts and no difference. It seems loud in car but can't be heard from outside.

I had the Infiniti dealer look at it and they said replace strut bushings (they were not replaced when struts replace because not in stock and looked good). They also said top links were bad. The top links seemed fine to me but I replaced all the strut bushings and top links. I did the work myself because they wanted $1100 and parts for me to do it were about $250.
Still same problem.

Had car aligned and checked and alignment shop found no problems.

Car drives fine and steering feels fine.
I have checked every bolt I could reach and used a pull bar to wiggle and check for loose parts and suspension pieces including lower ball joints. I checked the exhaust and it moves but doesn't hit anything. If you bang on the bumper and hood they make a little noise but I can't find anything loose and this noise sounds like something heavy. It can also happen on a sharp speed bump while traveling slow. Happens at the end of the speed bump.

Any ideas? I don't want to throw any more money at it.

boluca
08-17-2009, 01:07 PM
If anyone hits a similiar problem it turns out the front motor mount was bad. It didn't look bad but it was very weak and let the engine move too much. The noise was the air breather box bumping the strut tower. Replaced the motor mount and all is working properly.